Humankind

Compatibility: Super Pack and Vanilla Improvement for Humankind

Released (updated ago). Ranked 4 of 1,986 with 10,589 (11 today) downloads

Published by Uncle2fire (mod ID: 1727928)

load_order.jpg

By loading this mod in addition to my Culture Super Pack and DocktorKain's Vanilla Improvement Project you can play with both mods enabled and no conflicts.

The load order of the Super Pack and Vanilla Improvement Project shouldn't matter, but you must load this mod AFTER both of them. That is, you need to select the Super Pack and Vanilla Improvement Project first, then select this mod, then click "Apply".

See the screenshot for a visual to go along with the instructions.

________________

If you want to play with the Extended Naval Combat mod enabled alongside the Super Pack and Vanilla Improvement Project, you will need to use the Triple Alliance Patch instead. Do not load this patch alongside the Triple Alliance Patch.

________________

If you encounter bugs, please let me know! You can find me on Reddit, Steam, and Discord under the name uncle2fire.

Dependencies

NameAddedUpdated
Culture Super Pack
Vanilla Improvement Project

Releases

FilenameSizeVersionAddedOptions
comp_super_pack_vip1.7.zip16.99kb1.7

comp_super_pack_vip1.6.zip18.46kb1.6

comp_super_pack_vip.zip111.28kb1.5

132894218017702804_1727928.zip58.47kb1.4

132884673657869254_1727928.zip58.31kb1.3

132878422292828624_1727928.zip58.3kb1.2.0

132875411141955082_1727928.zip61.54kb1.1.0

132869204941778691_1727928.zip18.72kb1.0.1

18 comments

Join the community or sign in with your gaming account to join the conversation:

proussel59
proussel59 @proussel59

I have a message saying "one of the mod prevent the game from running properly" (translated from french, maybe not exact wording in english). Both culture pack and vanilla improvement work separately. I'm guessing it has to do with the update but the strange thing is that I don't own the update and it worked fine yesterday evening

Uncle2fire
Uncle2fire @uncle2fire

This mod hasn't been updated for the newest free game patch, or for the newest versions of the VIP or Super Pack mods. I'll release an update soon, but as of now I wouldn't expect this mod to work.

CB
CusoBT @cusobt

Oh, so this was the problem. Came here to ask the same, but glad to have confirmation. Thanks for working on an update!

d_elph
d_elph @d-elph

Getting a Mismatched mods error on this even when using the Compatibility patch.

Uncle2fire
Uncle2fire @uncle2fire

The Metternich update broke all mods. You'll need to wait for this mod to updated for Metternich in order to play it.

Silver_Weed
Silver_Weed @silver-weed

Hello, can this compat patch be updated for the Bolivar update? Since Extended Naval combat has not been updated for some time and only VIP and your Culture Super Pack are the only ones that has been updated.

Uncle2fire
Uncle2fire @uncle2fire

I'm currently working on an update for this patch. I hope to finish it in the next few days.

Chunwa
Chunwa @chunwa

How is the update for the new update cojming along?

Uncle2fire
Uncle2fire @uncle2fire

I have a working patch that I’ll hopefully be able to upload tonight.

Chunwa
Chunwa @chunwa

Thanks for the hard work

Uncle2fire
Uncle2fire @uncle2fire

Thanks :)

DocktorKain
DocktorKain @docktorkain

Just a headsup, the compatibility patch is updated and ready to go

MaxCheng95
MaxCheng95 @maxcheng95

This patch has broken so many other mods for me at once lol I have vip, super pack, naval combat, deepsea, buyit enabled along with all combability patch and the following happened:
1) it breaks the technology deepsea buildings get unlocked and made most stuff available at all times
2) it causes train stations and airports unlock tech modified by naval combat to duplicate, plus it broke the rifle unlock tech
3) the doctor kain pollution rework integration into naval combat mod doesn't work with this patch on
And all of the above was caused singlehandedly by this patch. Please update and fix it.

DocktorKain
DocktorKain @docktorkain

We're working on that, but found out that it is VERY labour-intensive. We'll keep you updated.

Lecgiu
Lecgiu @lecgiu

Thanks.

Uncle2fire
Uncle2fire @uncle2fire

You're welcome :)

Chinag
Chinag @chinag

May I ask what changes you did to make it compatible?

DocktorKain
DocktorKain @docktorkain

Mostly changes to technologies, to ensure the units would unlock at the correct techs.